Configuração do php.ini

Bom dia galera!!!

Conforme a galera vai pedindo e quando possível estou tentando ajudar. Bom sempre me deparo com perguntas/problemas referente a configuração do PHP para os aplicativos web (GLPI, Acesso a LDAP e etc), ai resolvi postar o arquivo que utilizado na minha base de testes Xampp.

Essas configurações vale tanto no Windows quanto no Linux, basta apenas verificar e alterar o que irá lhe atender.

Algumas configurações mais pedidas:

;Configuração do Serviço IMAP
extension=php_imap.dll
;Configuração para acesso a LDAP(AD)
extension=php_ldap.dll

Download “Configuração do php.ini” php.ini_.zip – Baixado 8773 vezes – 25 KB


# A T U A L I Z A Ç Ã O

Já no Linux é diferente, no arquivo php.ini ficam algumas configurações porem nem todas são feitas nele, pois você precisa ter instalado os pacotes extras como por exemplo “php5-ldap” e no diretório /etc/php5/conf.d vai existir um arquivo ldap.ini ativando o módulo LDAP e assim com os outros.

Desculpe não ter detalhado mais.

6 respostas para “Configuração do php.ini”

  1. Bom dia,

    Primeiramente parabéns por ajudar-nos com esses materiais.

    Bom estou tentando ativar o LDAP do php (wampserver 2.5) mas não consigo de forma alguma, já pesquisei vários artigos no google e vários fórum. Não consigo de forma alguma ativar o LDAP nem no wampserver nem no xampp. Você pode me aujdar a resolver isso? Você tem algum tutorial para resolver isso?

    Obrigado.

  2. Thiago estou com o mesmo problema do amigo acima, porém estou usando o windows server 2008, e quando vou na opção autenticação do GLPI, estou usando a ultima versão do GLPI 0.84.7, e aparece o seguindo erro, não consigo corrigir.

    “A extensão LDAP não está instalada em seu PHP
    Impossivel usar LDAP como fonte externa de comunicação”

  3. Bom Dia,

    Estou com esse problema também no acesso do GLPI / AD, aparece esse mensagem:

    Configuração LDAP
    A extensão LDAP não esta instalado em seu PHP
    Impossivel usar LDAP como fonte externa de comunicação

    Já tentei instalar um pacote:
    root@SRV-#####:/# dpkg -i slapd_2.4.28-1.1ubuntu4_i386.deb
    dpkg: quanto a slapd_2.4.28-1.1ubuntu4_i386.deb, contendo slapd, problema de pré-dependência:
    slapd pré-depende de multiarch-support
    multiarch-support não está instalado.
    dpkg: erro processando slapd_2.4.28-1.1ubuntu4_i386.deb (–install):
    problema de pré-dependência – slapd não será instalado
    Erros foram encontrados durante o processamento de:
    slapd_2.4.28-1.1ubuntu4_i386.deb

    Olha na pasta do /etc/php5/conf.d, verifiquei que não tem o arquivo ldap.ini.

    Vc pode me ajudar, fico grato.

Os comentários estão desativados.